Transactional Email, Fax Services Inbound, Fax Services Outbound
May 30, 2025 18:48 UTC
[Resolved] The issue within our SG1 datacenter has been fully resolved. All affected services are now operating normally and no further impact is expected.
May 30, 2025 17:59 UTC
[Identified] We are currently experiencing intermittent issues within our SG1 datacenter. Our teams are already fully engaged in resolution efforts. This may cause processing delays or degraded performance for some services hosted in SG1. We will provide updates as they occur.